Issue was resolved and all the payments were resynced.
Resolved
Identified
We've identified desynchronization between the dashboard payment's statuses and real payment status. Team is currently working in the fix